Degraded performance on Planning
Incident Report for Wello Solutions
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 12:31 CET
Monitoring
We’re excited to announce that a new release has gone live today, addressing an issue regarding session refresh performance. This fix marks an additional improvement in our ongoing efforts to optimize performance. With the most urgent actions addressed, we’re committed to further enhancing performance across the board.

While the system performance should already be noticeably improved, we’re determined to take it to the next level. In addition to the session refresh fix, we’ve also made significant progress on the login service. We anticipate rolling out the final fix and solution within a few days.

Stay tuned for more updates coming your way soon!
Posted Jan 31, 2024 - 09:52 CET
Update
We’re pleased to share that we have achieved notable advancements in our ongoing system enhancements. Our development team has diligently crafted an optimization update that is set to launch shortly, which promises to address and refine the loading times experienced within various sections of our platform.

In addition, we have conducted a thorough analysis of the system’s performance, laying the groundwork for strategic improvements. Our dedicated efforts aim to elevate the platform’s functionality to not only meet but exceed user expectations.

We are optimistic that these developments will significantly enhance your experience, and we eagerly anticipate your feedback on the improvements.
Posted Jan 23, 2024 - 16:31 CET
Investigating
Some users may experience degraded performance on planning jobs, location search or work order creation.
Posted Jan 22, 2024 - 15:25 CET
This incident affected: Wello Web Application.