Issue Login Portal
Incident Report for Wello Solutions
Resolved
This morning, we started to receive notification that it was not possible to log anymore on the online portal. After few investigation, we found that it was related to a DNS issue of one of our provider. Odyssee was not the only one impacted, thousands of companies in Europe were impacted. All is now back
Posted Oct 13, 2021 - 09:30 CEST